Skip to main content

Reply to this post | Go Back
View Post [edit]

Poster: guyzilla Date: Sep 16, 2010 9:23pm
Forum: feature_films Subject: Copyright question about "I Bury The Living"

I know this film used to be here but was taken down for some reason. I said I would put it back up when I found my copy because I was told it was PD. Anyway, I found my copy and when I played it I saw what looks like a valid notice on the opening credits,the copyright symbol, the word "copyright", the year, and the owner's name (production company). Since this was made before 1963, has the copyright been renewed? Moongleam, maybe you would know. If it turns out to be ok, I'll have it up ASAP.

Reply to this post
Reply [edit]

Poster: Mystic550 Date: Sep 16, 2010 11:33pm
Forum: feature_films Subject: Re: Copyright question about 'I Bury The Living'

According to Video Cellar the renewal was invalid since it was filed by a scam company that had no rights to renew the copyright.

http://www.archive.org/post/321256/i-bury-the-living

Reply to this post
Reply [edit]

Poster: guyzilla Date: Sep 17, 2010 1:08am
Forum: feature_films Subject: Re: Copyright question about 'I Bury The Living'

Thanks for refreshing my memory. I felt fairly certain but it doesn't hurt to double-check. OK, expect to see it here soon.

Reply to this post
Reply [edit]

Poster: Detective John Carter of Mars Date: Sep 18, 2010 4:34pm
Forum: feature_films Subject: Re: Copyright question about 'I Bury The Living'

@some reason

uploader had emptied the item